Thread (4 messages) flat view 4 messages, 4 authors, 2014-07-08

Re: [PATCHv2 net-next] net: filter: move load_pointer() into filter.h

From: David Miller <davem@davemloft.net>
Date: 2014-07-08 21:11:40
Also in: lkml

From: Zi Shen Lim <redacted>
Date: Thu,  3 Jul 2014 07:56:54 -0700
load_pointer() is already a static inline function.
Let's move it into filter.h so BPF JIT implementations can reuse this
function.

Since we're exporting this function, let's also rename it to
bpf_load_pointer() for clarity.

Signed-off-by: Zi Shen Lim <redacted>
---
v1->v2:
* Renamed to more specific name of bpf_load_pointer(), as suggested
  by Daniel.
Applied, thank you.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help