Re: [net-next 00/10] Add Geneve
From: Or Gerlitz <hidden>
Date: 2014-07-24 06:58:34
On Tue, Jul 22, 2014 at 1:19 PM, Andy Zhou [off-list ref] wrote:
Following patches adds initial support for Geneve tunnel protocol
Just to make this a bit more clear, would it be correct to say that the logical ordering here is as follows:
1. Add common UDP tunnel code into UDP tunnel support function 2. Refactor vxlan driver to make use of the UDP tunnel support 3. Add Geneve driver.
implemented by patches 1-5 below)
Andy Zhou (5): net: Rename ndo_add_vxlan_port to ndo_add_udp_tunnel_port. udp: Expand UDP tunnel common APIs vxlan: Remove vxlan_get_rx_port() net: Refactor vxlan driver to make use of common UDP tunnel functions net: Add Geneve tunneling protocol driver
and on top of that
4. Refactor Openvswitch in preparation for #5 5. Add Geneve support to Openvswitch.
implemented by patches 6-10 (below)
Jesse Gross (5): openvswitch: Eliminate memset() from flow_extract. openvswitch: Add support for matching on OAM packets. openvswitch: Wrap struct ovs_key_ipv4_tunnel in a new structure. openvswitch: Factor out allocation and verification of actions. openvswitch: Add support for Geneve tunneling.
I understand the wish to eventually have something that goes beyond refactoring of the vxlan and tunneling code plus Geneve basics. However, isn't the 1st part of the series (patches 1-5) have something is common to Tom's GUE work, which is currently under review too? I think we need first see how the basic elements from your series go along together with GUE. Or.