Thread (30 messages) flat view 30 messages, 8 authors, 2014-07-24

Re: [net-next 01/10] net: Rename ndo_add_vxlan_port to ndo_add_udp_tunnel_port.

From: Varka Bhadram <hidden>
Date: 2014-07-22 10:50:43

On 07/22/2014 03:49 PM, Andy Zhou wrote:

(...)
quoted hunk ↗ jump to hunk
  
-/* Calls the ndo_add_vxlan_port of the caller in order to
+/* Calls the ndo_add_tunnel_port of the caller in order to
   * supply the listening VXLAN udp ports. Callers are expected
- * to implement the ndo_add_vxlan_port.
+ * to implement the ndo_add_tunnle_port.
   */
  void vxlan_get_rx_port(struct net_device *dev)
  {
@@ -2206,8 +2209,8 @@ void vxlan_get_rx_port(struct net_device *dev)
  		hlist_for_each_entry_rcu(vs, &vn->sock_list[i], hlist) {
  			port = inet_sk(vs->sock->sk)->inet_sport;
  			sa_family = vs->sock->sk->sk_family;
-			dev->netdev_ops->ndo_add_vxlan_port(dev, sa_family,
-							    port);
+			dev->netdev_ops->ndo_add_udp_tunnel_port(dev,
+					sa_family, port, UDP_TUNNEL_TYPE_VXLAN);
Should match open parenthesis:
	dev->netdev_ops->ndo_add_udp_tunnel_port(dev,
						 sa_family, port,
						 UDP_TUNNEL_TYPE_VXLAN);
  

-- 
Regards,
Varka Bhadram.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help