Re: [PATCH] fec: Unify fec_ptp.c and fec.c
From: Frank Li <hidden>
Date: 2013-03-21 10:15:30
2013/3/21 Uwe Kleine-König [off-list ref]:
Hello, On Thu, Mar 21, 2013 at 06:02:02PM +0800, Frank Li wrote:quoted
I suggest use below patch to fix this problem--- a/drivers/net/ethernet/freescale/Makefile +++ b/drivers/net/ethernet/freescale/Makefile@@ -2,7 +2,8 @@ # Makefile for the Freescale network device drivers. # -obj-$(CONFIG_FEC) += fec.o fec_ptp.o +obj-$(CONFIG_FEC) += fec_driver.o +fec_driver-objs := fec.o fec_ptp.o obj-$(CONFIG_FEC_MPC52xx) += fec_mpc52xx.o ifeq ($(CONFIG_FEC_MPC52xx_MDIO),y) obj-$(CONFIG_FEC_MPC52xx) += fec_mpc52xx_phy.oI thought about suggesting something similar, too. I would have renamed fec.c to (say) fec_base.c and then kept the module name fec.ko. Not sure keeping the module name is critical.
Okay, how about rename fec.c to fec_main.c?
What is missing from your patch is dropping the EXPORT_SYMBOLs. Other than that I like it better than using a single .c file.
There are not EXPORT_SYMBOL in my fec.c? which version do you use?
Best regards Uwe -- Pengutronix e.K. | Uwe Kleine-König | Industrial Linux Solutions | http://www.pengutronix.de/ |