Re: [PATCH v7 06/16] tracepoint: use new hashtable implementation
From: Sasha Levin <hidden>
Date: 2012-10-29 19:17:40
Also in:
dm-devel, linux-mm, linux-nfs, lkml
From: Sasha Levin <hidden>
Date: 2012-10-29 19:17:40
Also in:
dm-devel, linux-mm, linux-nfs, lkml
On Mon, Oct 29, 2012 at 3:12 PM, Tejun Heo [off-list ref] wrote:
On Mon, Oct 29, 2012 at 03:09:36PM -0400, Sasha Levin wrote:quoted
The other thing is whether hash_init() should be called for hashtables that were created with DEFINE_HASHTABLE(). That point was raised by Neil Brown last time this series went around, and it seems that no one objected to the point that it should be consistent across the code.Hmmm? If something is DEFINE_XXX()'d, you definitely shouldn't be calling XXX_init() on it. That's how it is with most other abstract data types and you need *VERY* strong rationale to deviate from that.
Neil Brown raised that point last time that this series went around, and suggested that this should be consistent and hash_init() would appear everywhere, even if DEFINE_HASHTABLE() was used. Since no one objected to that I thought we're going with that. I'll chalk it up to me getting confused :) Thanks, Sasha -- To unsubscribe from this list: send the line "unsubscribe linux-nfs" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html