On Mon, Oct 29, 2012 at 03:09:36PM -0400, Sasha Levin wrote:
The other thing is whether hash_init() should be called for hashtables
that were created with DEFINE_HASHTABLE(). That point was raised by
Neil Brown last time this series went around, and it seems that no one
objected to the point that it should be consistent across the code.
Hmmm? If something is DEFINE_XXX()'d, you definitely shouldn't be
calling XXX_init() on it. That's how it is with most other abstract
data types and you need *VERY* strong rationale to deviate from that.
Thanks.
--
tejun