Re: [PATCH] net: compare_ether_addr[_64bits]() has no ordering
From: David Miller <davem@davemloft.net>
Date: 2012-05-07 23:21:58
From: Johannes Berg <johannes@sipsolutions.net> Date: Mon, 07 May 2012 16:12:41 +0200
On Mon, 2012-05-07 at 15:53 +0200, Eric Dumazet wrote:quoted
On Mon, 2012-05-07 at 15:39 +0200, Johannes Berg wrote:quoted
From: Johannes Berg <redacted> Neither compare_ether_addr() nor compare_ether_addr_64bits() (as it can fall back to the former) have comparison semantics like memcmp() where the sign of the return value indicates sort order. We had a bug in the wireless code due to a blind memcmp replacement because of this. A cursory look suggests that the wireless bug was the only one due to this semantic difference. Signed-off-by: Johannes Berg <redacted> --- include/linux/etherdevice.h | 11 ++++++----- 1 file changed, 6 insertions(+), 5 deletions(-)The right way to avoid this kind of problems is to change these functions to return a boolWell, I guess so, but that'd be a weird thing for a compare_ function... should probably be named equal_... then, but I'm not really able to do such a huge change on the first day after my vacation :-)
It's true the name could be improved, but changing the name is quite a large undertaking even with automated scripts. Even the bool change is slightly painful, since all of the explicit tests against integers (%99.999 of these are in wireless BTW :-) would need to be adjusted. For now, I'll just apply Johannes's comment fix.