Re: [PATCH] iwlwifi: fix skb truesize underestimation From: Eric Dumazet <hidden> Date: 2012-03-24 00:22:27 On Fri, 2012-03-23 at 17:05 -0700, Eric Dumazet wrote:+ if (len) { + int offset = (void *)hdr + hdrlen - rxb_addr(rxb); + + skb_add_rx_frag(skb, 0, rxb_steal_page(rxb), offset, + len, rxb->truesize); + } iwl_update_stats(priv, false, fc, len); Please delete this patch, I'll send a v2 : iwl_update_stats() should be called with original "len", not "len - hdrlen"
Keyboard shortcuts hback out one level jnext message in thread kprevious message in thread ldrill in Escclose help / fold thread tree ?toggle this help