From: Vasiliy Kulikov <redacted>
Date: Fri, 25 Feb 2011 18:14:14 +0300
Since a8f80e8ff94ecba629542d9b4b5f5a8ee3eb565c any process with
CAP_NET_ADMIN may load any module from /lib/modules/. This doesn't mean
that CAP_NET_ADMIN is a superset of CAP_SYS_MODULE as modules are limited
to /lib/modules/**. However, CAP_NET_ADMIN capability shouldn't allow
anybody load any module not related to networking.
Why go through this naming change, which does break things, instead of
simply adding a capability mask tag or similar to modules somehow. You
could stick it into a special elf section or similar.
Doesn't that make tons more sense than this?