Re: [PATCH] mac8390: change an error return code and some cleanup, take 4
From: Finn Thain <hidden>
Date: 2010-05-31 12:55:25
Also in:
linux-m68k, lkml
From: Finn Thain <hidden>
Date: 2010-05-31 12:55:25
Also in:
linux-m68k, lkml
On Mon, 31 May 2010, David Miller wrote:
From: fthain@telegraphics.com.au Date: Mon, 31 May 2010 21:07:09 +1000 (EST)quoted
Apparently David now wants me to submit this again -- if (ei_debug) pr_debug(...) David, if that code is acceptable, please let me know.The only thing I care about is at the moment that you don't do something that ends up dropping the pr_fmt prefix. The pr_fmt define at the beginning of the driver is for nothing if we end up adding exceptions that end up eliding it for no good reason. And that's what your patch was doing.
Since you have rejected my most recent patch submission, which uses pr_fmt explicitly, I imagine that what you are trying to say here is that only pr_debug or pr_info are acceptable. Now, so that we don't have to go through pointless resubmission iterations, can you tell me which of the following you prefer: if (ei_debug) pr_debug(...) OR if (ei_debug) pr_info(...) Thanks. Finn