From: Linus Torvalds <torvalds@linux-foundation.org>
Date: Tue, 16 Jun 2009 11:59:34 -0700 (PDT)
At the very least, add a helper function for "do I actually have
outstanding allocations" or something like that. IOW, do a
/*
* Comment here about that magical "1"
*/
static inline int sk_has_allocations(struct sock *sk)
{
return atomic_read(&sk->sk_wmem_alloc) > 1 ||
atomic_read(&sk->sk_rmem_alloc);
}
and then make the various network protocols use that, rather than
open-coding some random internal implementation magic.
I agree, this should be handled with a helper function
abstraction rather than putting "1" checks all over the place.