Ragner Magalhaes wrote:
ext Brian King wrote:
quoted
Ragner Magalhaes wrote:
quoted
here also, as above ...
quoted
+ if (data && (dev->features & NETIF_F_IP_CSUM))
+ return 0;
+ if (!data && !(dev->features & NETIF_F_IP_CSUM))
+ return 0;
This change would make the line > 80 columns, which I prefer to avoid.
Updated patch attached which addresses the first comment.
I think would not be ugly to make.
if ((data && (dev->features & NETIF_F_IP_CSUM)) ||
(!data && !(dev->features & NETIF_F_IP_CSUM)))
return 0;
I find that less readable than what I currently have.
-Brian
--
Brian King
Linux on Power Virtualization
IBM Linux Technology Center