Re: [patch sungem] improved locking
From: David Miller <davem@davemloft.net>
Date: 2006-11-09 23:04:28
From: David Miller <davem@davemloft.net>
Date: 2006-11-09 23:04:28
Please use GREG_STAT_* instead of magic constants for the
interrupt mask and ACK register writes. In fact, there are
some questionable values you use, in particular this one:
+static inline void gem_ack_int(struct gem *gp)
+{
+ writel(0x3f, gp->regs + GREG_IACK);
+}
There is no bit defined in GREG_STAT_* for 0x08, but you
set it in this magic bitmask. It is another reason not
to use magic constants like this :-)
Also, if you need to use an attachment to get the tabbing
right, that's fine, but please also provide a copy inline
so that it is easy to quote the patch for review purposes.
It's a truly a pain in the rear to quote things when you use
a binary attachment.
I'd like these very simple and straightforward issues to
be worked out before I even begin to review the actual
locking change itself.