Hi,
drivers/net/ehea/ehea.h | 452
+#define EHEA_DRIVER_NAME "IBM eHEA"
You are using this for ethtool get_drvinfo. Im not sure if it should
match the module name, and I worry about having a space in the name. Any
ideas on what we should be doing here?
+#define NET_IP_ALIGN 0
Shouldnt override this in your driver.
+#define EDEB_P_GENERIC(level, idstring, format, args...) \
+#define EDEB_P_GENERIC(level,idstring,format,args...) \
+#define EDEB(level, format, args...) \
+#define EDEB_ERR(level, format, args...) \
+#define EDEB_EN(level, format, args...) \
+#define EDEB_EX(level, format, args...) \
+#define EDEB_DMP(level, adr, len, format, args...) \
There are a lot of debug statements in the driver. When doing a review
I stripped them all out to make it easier to read. As suggested by
others, using the standard debug macros (where still required) would be
a good idea.
Anton