On Wed, 2003-09-24 at 10:17, Joe Perches wrote:
On Wed, 2003-09-24 at 10:13, Linus Torvalds wrote:
quoted
Looks sane, but wouldn't it be cleaner to put this ugly special case logic
with casts etc in an inline function and make the code a bit more readable
at the same time?
I've got those.
I've done the ((void*)1) conversions to PKT_SHARED_SKBs
and found this missing. I'll submit those separately.
diff -urN linux-2.6.0-test5/include/linux/netdevice.h shared_skb/include/linux/netdevice.h
-- linux-2.6.0-test5/include/linux/netdevice.h 2003-09-22 08:04:03.000000000 -0700
+++ shared_skb/include/linux/netdevice.h 2003-09-22 13:10:07.000000000 -0700
@@ -477,6 +477,7 @@
*/
#define SET_NETDEV_DEV(net, pdev) ((net)->class_dev.dev = (pdev))
+#define PKT_CAN_SHARE_SKB ((void*)1)
struct packet_type
{