On Wed, 24 Sep 2003, Joe Perches wrote:
Symmetric to dev_add_pack.
Looks sane, but wouldn't it be cleaner to put this ugly special case logic
with casts etc in an inline function and make the code a bit more readable
at the same time?
David?
Linus
quoted hunk ↗ jump to hunk
diff -urN linux-2.6.0-test5/net/core/dev.c shared_skb/net/core/dev.c
--- linux-2.6.0-test5/net/core/dev.c 2003-09-22 08:04:06.000000000 -0700
+++ shared_skb/net/core/dev.c 2003-09-22 14:02:08.000000000 -0700
@@ -281,7 +281,7 @@
list_for_each_entry(pt1, head, list) {
if (pt == pt1) {
#ifdef CONFIG_NET_FASTROUTE
- if (pt->data)
+ if (pt->data && (long)pt->data != 1)
netdev_fastroute_obstacles--;
#endif
list_del_rcu(&pt->list);