Re: [PATCH v3 05/13] mm: introduce CONFIG_ARCH_LAZY_MMU
From: Kevin Brodsky <hidden>
Date: 2025-10-20 10:37:50
Also in:
linux-arm-kernel, linux-mm, lkml, sparclinux, xen-devel
From: Kevin Brodsky <hidden>
Date: 2025-10-20 10:37:50
Also in:
linux-arm-kernel, linux-mm, lkml, sparclinux, xen-devel
On 18/10/2025 11:52, Mike Rapoport wrote:
quoted
@@ -231,7 +231,7 @@ static inline int pmd_dirty(pmd_t pmd) * held, but for kernel PTE updates, no lock is held). Nesting is not permitted * and the mode cannot be used in interrupt context. */ -#ifndef __HAVE_ARCH_ENTER_LAZY_MMU_MODE +#ifndef CONFIG_ARCH_LAZY_MMU static inline void arch_enter_lazy_mmu_mode(void) {} static inline void arch_leave_lazy_mmu_mode(void) {} static inline void arch_flush_lazy_mmu_mode(void) {}diff --git a/mm/Kconfig b/mm/Kconfig index 0e26f4fc8717..2fdcb42ca1a1 100644 --- a/mm/Kconfig +++ b/mm/Kconfig@@ -1372,6 +1372,9 @@ config PT_RECLAIM config FIND_NORMAL_PAGE def_bool n +config ARCH_LAZY_MMU + bool +I think a better name would be ARCH_HAS_LAZY_MMU and the config option fits better to arch/Kconfig.
Sounds fine by me - I'm inclined to make it slightly longer still, ARCH_HAS_LAZY_MMU_MODE, to avoid making "LAZY_MMU" sound like some HW feature. - Kevin