Thread (23 messages) 23 messages, 6 authors, 2025-07-01

Re: [PATCH v2 01/11] kasan: unify static kasan_flag_enabled across modes

From: Andrew Morton <akpm@linux-foundation.org>
Date: 2025-07-01 00:05:45
Also in: linux-mm, linux-riscv, linux-s390, linux-um, lkml, llvm, loongarch

On Mon, 30 Jun 2025 14:31:00 +0200 Alexander Gordeev [off-list ref] wrote:
quoted
+/*
+ * Initialize Generic KASAN and enable runtime checks.
+ * This should be called from arch kasan_init() once shadow memory is ready.
+ */
+void __init kasan_init_generic(void)
+{
+	static_branch_enable(&kasan_flag_enabled);
s390 crashes at this line, when the whole series is applied.
oop.  Thanks, I'll demote this seres to the mm-new branch for now, which
takes it out of linux-next.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help