Re: [PATCH v2 00/11] kasan: unify kasan_arch_is_ready with kasan_enabled
From: Andrey Konovalov <andreyknvl@gmail.com>
Date: 2025-06-28 10:57:00
Also in:
linux-mm, linux-riscv, linux-s390, linux-um, lkml, llvm, loongarch
On Thu, Jun 26, 2025 at 5:32 PM Sabyrzhan Tasbolatov [off-list ref] wrote:
This patch series unifies the kasan_arch_is_ready() and kasan_enabled() interfaces by extending the existing kasan_enabled() infrastructure to work consistently across all KASAN modes (Generic, SW_TAGS, HW_TAGS). Currently, kasan_enabled() only works for HW_TAGS mode using a static key, while other modes either return IS_ENABLED(CONFIG_KASAN) (compile-time constant) or rely on architecture-specific kasan_arch_is_ready() implementations with custom static keys and global variables. This leads to: - Code duplication across architectures - Inconsistent runtime behavior between KASAN modes - Architecture-specific readiness tracking After this series: - All KASAN modes use the same kasan_flag_enabled static key - Consistent runtime enable/disable behavior across modes - Simplified architecture code with unified kasan_init_generic() calls - Elimination of arch specific kasan_arch_is_ready() implementations - Unified vmalloc integration using kasan_enabled() checks This addresses the bugzilla issue [1] about making kasan_flag_enabled and kasan_enabled() work for Generic mode, and extends it to provide true unification across all modes. [1] https://bugzilla.kernel.org/show_bug.cgi?id=217049
Hi Sabyrzhan, Thank you for working on this! One aspect that is missing from the patches is moving the kasan_arch_is_ready() calls into the include/linux/kasan.h (this is not explicitly mentioned in the issue, but this is what the "adding __wrappers" part is about). Another thing that needs careful consideration is whether it's possible to combine kasan_arch_is_ready() and kasan_enabled() into the same check logically at all. There's one issue mentioned in [1]:
In kasan_cache_create() we unconditionally allocate a metadata buffer, but the kasan_init_slab_obj() call to initialise it is guarded by kasan_enabled(). But later parts of the code only check the presence of the buffer before using it, so bad things happen if kasan_enabled() later turns on (I was getting some error about invalid lock state).
And there might be other callbacks that should be executed even before kasan_init_...() completes. But then for the HW_TAGS mode, if kasan_enabled() is off, then we don't want to execute any callbacks. So maybe we do actually need a separate static key for kasan_arch_is_ready(). But even if so, it still makes sense to move kasan_arch_is_ready() into the __wrappers for the affected callbacks. Thanks! [1] https://lore.kernel.org/linux-mm/CA+fCnZf7JqTH46C7oG2Wk9NnLU7hgiVDEK0EA8RAtyr-KgkHdg@mail.gmail.com/ (local)