On Fri 2023-05-05 09:38:14, Doug Anderson wrote:
Hi,
On Thu, May 4, 2023 at 8:02 PM Nicholas Piggin [off-list ref] wrote:
quoted
On Fri May 5, 2023 at 8:13 AM AEST, Douglas Anderson wrote:
quoted
These are tiny style changes:
- Add a blank line before a "return".
- Renames two globals to use the "watchdog_hld" prefix.
Particularly static ones don't really need the namespace prefixes.
Renames are mostly at Petr's request. If I've misunderstood what he
wants here that I'm happy to remove them.
IMHO, the namespace prefix makes sense here to distinguish hardlockup
and softlockup specific code. The original names did this as well
but they were another variants of the naming scheme mess.
IMHO, even longer prefix is better than a mess.
quoted
Not sure if processed is better than warn.
I can undo this one if you want. It felt like we were doing more than
just warning, but if people think "warn" is a better way to describe
it then that's fine with me.
The code seems to only print the warning and dump a lot of debug
information. Both _warned or _processed look good to me.
quoted
allcpu_dumped is better
than dumped_stacks though because the all-CPUs-dump is a particular
thing.
OK, I can undo this and leave it as "allcpu_dumped".
I do not have strong opinion. Well, "allcpu" is another inconsistency
vs. "all_cpu" in sysctl_hardlockup_all_cpu_backtrace. So, it should
be "all_cpu_dumped".
Feel free to use:
Reviewed-by: Petr Mladek <pmladek@suse.com>
Best Regards,
Petr