On Tue 2022-05-17 13:42:06, Guilherme G. Piccoli wrote:
On 17/05/2022 10:57, Petr Mladek wrote:
quoted
quoted
Disagree here, I'm CCing Florian for information.
This notifier preserves RAM so it's *very interesting* if we have
kmsg_dump() for example, but maybe might be also relevant in case kdump
kernel is configured to store something in a persistent RAM (then,
without this notifier, after kdump reboots the system data would be lost).
I see. It is actually similar problem as with
drivers/firmware/google/gsmi.c.
I does similar things like kmsg_dump() so it should be called in
the same location (after info notifier list and before kdump).
A solution might be to put it at these notifiers at the very
end of the "info" list or make extra "dump" notifier list.
Here I still disagree. I've commented in the other response thread
(about Google gsmi) about the semantics of the hypervisor list, but
again: this list should contain callbacks that
(a) Should run early, _by default_ before a kdump;
(b) Communicate with the firmware/hypervisor in a "low-risk" way;
Imagine a scenario where users configure kdump kernel to save something
in a persistent form in DRAM - it'd be like a late pstore, in the next
kernel. This callback enables that, it's meant to inform FW "hey, panic
happened, please from now on don't clear the RAM in the next FW-reboot".
I don't see a reason to postpone that - let's see if the maintainers
have an opinion.
I have answered this in more detail in the other reply, see
https://lore.kernel.org/r/YoShZVYNAdvvjb7z@alley (local)
I agree that both notifiers in
drivers/soc/bcm/brcmstb/pm/pm-arm.c
drivers/firmware/google/gsmi.c
better fit into the hypervisor list after all.
Best Regards,
Petr