Re: [PATCH v5 08/11] powerpc/pseries/iommu: Update remove_dma_window() to accept property name
From: Leonardo Brás <hidden>
Date: 2021-08-17 06:12:41
Also in:
lkml
On Tue, 2021-08-17 at 02:59 -0300, Leonardo Brás wrote:
Hello Fred, thanks for the feedback! On Tue, 2021-07-20 at 19:51 +0200, Frederic Barrat wrote:quoted
On 16/07/2021 10:27, Leonardo Bras wrote:quoted
Update remove_dma_window() so it can be used to remove DDW with a given property name. This enables the creation of new property names for DDW, so we can have different usage for it, like indirect mapping. Signed-off-by: Leonardo Bras <redacted> Reviewed-by: Alexey Kardashevskiy <redacted> --- arch/powerpc/platforms/pseries/iommu.c | 21 +++++++++++-------- -- 1 file changed, 11 insertions(+), 10 deletions(-)diff --git a/arch/powerpc/platforms/pseries/iommu.cb/arch/powerpc/platforms/pseries/iommu.c index 108c3dcca686..17c6f4706e76 100644--- a/arch/powerpc/platforms/pseries/iommu.c +++ b/arch/powerpc/platforms/pseries/iommu.c@@ -830,31 +830,32 @@ static void remove_dma_window(structdevice_node *np, u32 *ddw_avail, np, ret, ddw_avail[DDW_REMOVE_PE_DMA_WIN], liobn); } -static void remove_ddw(struct device_node *np, bool remove_prop) +static int remove_ddw(struct device_node *np, bool remove_prop, const char *win_name) {Why switch to returning an int? None of the callers check it.IIRC, in a previous version it did make sense, which is not the case anymore. I will revert this. Thanks!
Oh, sorry about that, it is in fact still needed: It will make sense in patch v5 10/11: On iommu_reconfig_notifier(), if (action == OF_RECONFIG_DETACH_NODE), we need to remove a DDW if it exists. As there may be different window names, it tests for DIRECT64_PROPNAME, and if it's not found, it tests for DMA64_PROPNAME. This approach will skip scanning for DMA64_PROPNAME if DIRECT64_PROPNAME was found, as both may not exist in the same node. But for this approach to work we need remove_ddw() to return error if the property is not found. Does it make sense? or should I just test for both? Best regards, Leonardo Bras