Thread (25 messages) flat view 25 messages, 11 authors, 2020-07-26

Re: [PATCH v2 1/3] module: Rename module_alloc() to text_alloc() and move to kernel proper

From: Jarkko Sakkinen <hidden>
Date: 2020-07-23 02:14:25
Also in: linux-riscv

On Thu, Jul 16, 2020 at 06:49:09PM +0200, Christophe Leroy wrote:
Jarkko Sakkinen [off-list ref] a écrit :
quoted
Rename module_alloc() to text_alloc() and module_memfree() to
text_memfree(), and move them to kernel/text.c, which is unconditionally
compiled to the kernel proper. This allows kprobes, ftrace and bpf to
allocate space for executable code without requiring to compile the modules
support (CONFIG_MODULES=y) in.
You are not changing enough in powerpc to have this work.
On powerpc 32 bits (6xx), when STRICT_KERNEL_RWX is selected, the vmalloc
space is set to NX (no exec) at segment level (ie by 256Mbytes zone) unless
CONFIG_MODULES is selected.

Christophe
This has been deduced down to:

https://lore.kernel.org/lkml/20200717030422.679972-1-jarkko.sakkinen@linux.intel.com/ (local)

I.e. not intruding PPC anymore :-)

/Jarkko
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help