Re: rename ->make_request_fn and move it to the block_device_operations v2

From
Jens Axboe <axboe@kernel.dk>
Date
2020-07-01 13:43:36
Also in
dm-devel, linux-bcache, linux-m68k, linux-nvme, linux-raid, linux-s390, lkml, nvdimm
Reply to
Christoph Hellwig, 2020-07-01
On 7/1/20 2:59 AM, Christoph Hellwig wrote:
Hi Jens,

this series moves the make_request_fn method into block_device_operations
with the much more descriptive ->submit_bio name.  It then also gives
generic_make_request a more descriptive name, and further optimize the
path to issue to blk-mq, removing the need for the direct_make_request
bypass.
Thanks, I'll try this again.

-- 
Jens Axboe
Thread (29 messages) 29 messages, 6 authors, last reply 2020-07-02
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help