On 2020-01-08 12:13 p.m., Dan Williams wrote:
On Wed, Jan 8, 2020 at 11:08 AM David Hildenbrand [off-list ref] wrote:
quoted
quoted
Am 08.01.2020 um 20:00 schrieb Dan Williams [off-list ref]:
On Wed, Jan 8, 2020 at 9:17 AM Logan Gunthorpe [off-list ref] wrote:
quoted
quoted
On 2020-01-08 5:28 a.m., David Hildenbrand wrote:
On 07.01.20 21:59, Logan Gunthorpe wrote:
quoted
The mhp_restrictions struct really doesn't specify anything resembling
a restriction anymore so rename it to be mhp_modifiers.
I wonder if something like "mhp_params" would be even better. It's
essentially just a way to avoid changing call chains rough-out all archs
whenever we want to add a new parameter.
Sure, that does sound a bit nicer to me. I can change it for v3.
Oh, I was just about to chime in to support "modifiers" because I
would expect all parameters to folded into a "params" struct. The
modifiers seem to be limited to the set of items that are only
considered in a non-default / expert memory hotplug use cases.
quoted
It‘s a set of extended parameters I‘d say.
Sure, we can call them "mhp_params" and just clarify that they are
optional / extended in the kernel-doc.
Well pgprot isn't going to be optional... But I'll add something to the
kernel_doc.
Logan