Hi!
quoted
quoted
quoted
You are right, but the current code is "interesting". What about
ws = NULL;
while (ws = wakeup_source_get_next(NULL)) ...
then?
Did you mean:
ws = NULL;
while (ws = wakeup_source_get_next(ws)) ...
Yes, that will be the same to my original logic, do you recommend
to change to this? :)
Yes please. It will be less confusing to the reader.
OK, if no other comment, I will work out v4, fix this and extra ','
quoted
Thanks (and sorry for cross-talk),
That's OK, thanks for your time.
You can add
Acked-by: Pavel Machek <redacted>
to that version.
Best regards,
Pavel
--
DENX Software Engineering GmbH, Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany