Re: [PATCH v6 01/17] powerpc/vas: Define macros, register fields and structures
flat view
From: Michael Ellerman <mpe@ellerman.id.au>
Date: 2017-08-14 05:21:51
Sukadev Bhattiprolu [off-list ref] writes:
Define macros for the VAS hardware registers and bit-fields as well as couple of data structures needed by the VAS driver. Signed-off-by: Sukadev Bhattiprolu <redacted> --- Changelog[v6] - Add some fields for FTW windows Changelog[v4] - [Michael Neuling] Move VAS code to arch/powerpc; Reorg vas.h and vas-internal.h to kernel and uapi versions; rather than creating separate properties for window context/address entries in device tree, combine them into "reg" properties; drop ->hwirq and irq_port fields from vas_window as they are only needed with user space windows. - Drop the error check for CONFIG_PPC_4K_PAGES. Instead in a follow-on patch add a "depends on CONFIG_PPC_64K_PAGES". Changelog[v3] - Rename winctx->pid to winctx->pidr to reflect that its a value from the PID register (SPRN_PID), not the linux process id. - Make it easier to split header into kernel/user parts - To keep user interface simple, use macros rather than enum for the threshold-control modes. - Add a pid field to struct vas_window - needed for user space send windows. Changelog[v2] - Add an overview of VAS in vas-internal.h - Get window context parameters from device tree and drop unnecessary macros. --- arch/powerpc/include/asm/vas.h | 35 ++++ arch/powerpc/include/uapi/asm/vas.h | 25 +++
I thought we weren't exposing VAS to userspace yet? If we are then we need to get things straight WRT copy/paste abort. cheers