Re: [PATCH v3 4/9] powerpc/powernv: Make power7_powersave_common more generic
flat view
From: Gautham R Shenoy <hidden>
Date: 2016-05-24 08:54:20
Also in:
lkml
Hi Shreyas, On Mon, May 23, 2016 at 08:48:37PM +0530, Shreyas B. Prabhu wrote:
quoted hunk ↗ jump to hunk
power7_powersave_common does common steps needed before entering idle state and eventually changes MSR to MSR_IDLE and does rfid to power7_enter_nap_mode. Move the updation of HSTATE_HWTHREAD_STATE to power7_powersave_common from power7_enter_nap_mode and make it more generic by passing the rfid address as a function parameter. Also make function name more generic. Reviewed-by: Gautham R. Shenoy <redacted> Signed-off-by: Shreyas B. Prabhu <redacted> --- Changes in v3: ============== - Moved HSTATE_HWTHREAD_STATE updation to power_powersave_common arch/powerpc/kernel/idle_power_common.S | 30 +++++++++++++++++------------- 1 file changed, 17 insertions(+), 13 deletions(-)diff --git a/arch/powerpc/kernel/idle_power_common.S b/arch/powerpc/kernel/idle_power_common.S index 973c9a1..d100577 100644 --- a/arch/powerpc/kernel/idle_power_common.S +++ b/arch/powerpc/kernel/idle_power_common.S@@ -74,8 +74,10 @@ core_idle_lock_held: * To check IRQ_HAPPENED in r4 * 0 - don't check * 1 - check + * + * Address to 'rfid' to in r5 */ -_GLOBAL(power7_powersave_common) +_GLOBAL(pnv_powersave_common)
You can move this rename to the previous patch where it fits better. [..snip..]
.globl power7_enter_nap_mode power7_enter_nap_mode:
Ditto. This should be "pnv_enter_idle_mode" in the previous patch. [..snip..]
_GLOBAL(power7_winkle) li r3,3
li r3,PNV_THREAD_WINKLE Which should be a separate patch.