2016-03-17 Joe Perches [off-list ref]:
On Thu, 2016-03-17 at 16:50 -0400, Rob Clark wrote:
quoted
On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches [off-list ref] wrote:
[]
quoted
quoted
It's a name that seems like it should be a straightforward
cast of a kernel pointer to a __user pointer like:
=20
static inline void __user *to_user_ptr(void *p)
{
=A0=A0=A0=A0=A0=A0=A0=A0return (void __user *)p;
}
ahh, ok.=A0=A0I guess I was used to using it in the context of ioctl
structs..=A0=A0in that context u64 -> (void __user *) made more sense.
=20
Maybe uapi_to_ptr()?=A0=A0(ok, not super-creative.. maybe someone has a
better idea)
=20
Maybe u64_to_user_ptr?
That is a good name. If everyone agrees I can resend this patch
changing it to u64_to_user_ptr. Then should we still keep it on
kernel.h?
Gustavo