Re: [PATCH v9 2/3] kernel.h: add to_user_ptr()
From: Joe Perches <joe@perches.com>
Date: 2016-03-17 20:22:43
Also in:
dri-devel, lkml
On Thu, 2016-03-17 at 15:43 -0300, Gustavo Padovan wrote:
2016-03-17 Gustavo Padovan [off-list ref]:quoted
2016-03-17 Joe Perches [off-list ref]:quoted
On Thu, 2016-03-17 at 14:30 -0300, Gustavo Padovan wrote:quoted
This function had copies in 3 different files. Unify them in kernel.h.This is only used by gpu/drm. I think this is a poor name for a generic function that would be in kernel.h. Isn't there an include file in linux/drm that's appropriate for this. Maybe drmP.h Maybe prefix this function name with drm_ too.No, the next patch adds a user to drivers/staging (which will be moved to drivers/dma-buf) soon. Maybe move to a different header in include/linux/? not sure which one.quoted
Also, there's this that might conflict: arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ptr_to_compat(p) arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ((unsigned long)(p))Right, I'll figure out how to replace these two too.The powerpc to_user_ptr has a different meaning from the one I'm adding in this patch. I propose we just rename powerpc's to_user_ptr to __to_user_ptr and leave the rest as is.
I think that's not a good idea, and you should really check this concept with the powerpc folk (added to to:s and cc:ed) If it were really added, then the function meaning is incorrect. This is taking a u64, casting that to (unsigned long/uint_ptr_t), then converting that to a user pointer. Does that naming and use make sense on x86-32 or arm32?