From: "Michael S. Tsirkin" <mst@redhat.com> Date: 2016-01-10 11:57:03
As part of memory barrier cleanup, this patchset
extends checkpatch to make it easier to stop
incorrect memory barrier usage.
This applies on top of my series
arch: barrier cleanup + barriers for virt
and will be included in the next version of the series.
Changes from v2:
catch optional\s* before () in barriers
rewrite using qr{} instead of map
Michael S. Tsirkin (3):
checkpatch.pl: add missing memory barriers
checkpatch: check for __smp outside barrier.h
checkpatch: add virt barriers
scripts/checkpatch.pl | 31 ++++++++++++++++++++++++++++++-
1 file changed, 30 insertions(+), 1 deletion(-)
--
MST
From: "Michael S. Tsirkin" <mst@redhat.com> Date: 2016-01-10 11:57:12
SMP-only barriers were missing in checkpatch.pl
Refactor code slightly to make adding more variants easier.
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
scripts/checkpatch.pl | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)
@@ -5116,7 +5116,25 @@ sub process {}}#checkformemorybarrierswithoutacomment.-if($line=~/\b(mb|rmb|wmb|read_barrier_depends|smp_mb|smp_rmb|smp_wmb|smp_read_barrier_depends)\(/){++my$barriers=qr{+mb|+rmb|+wmb|+read_barrier_depends+}x;+my$smp_barriers=qr{+store_release|+load_acquire|+store_mb|+($barriers)+}x;+my$all_barriers=qr{+$barriers|+smp_($smp_barriers)+}x;++if($line=~/\b($all_barriers)\s*\(/){if(!ctx_has_comment($first_line,$linenr)){WARN("MEMORY_BARRIER","memory barrier without comment\n".$herecurr);
From: "Michael S. Tsirkin" <mst@redhat.com> Date: 2016-01-10 11:57:22
Introduction of __smp barriers cleans up a bunch of duplicate code, but
it gives people an additional handle onto a "new" set of barriers - just
because they're prefixed with __* unfortunately doesn't stop anyone from
using it (as happened with other arch stuff before.)
Add a checkpatch test so it will trigger a warning.
Reported-by: Russell King <redacted>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
scripts/checkpatch.pl | 10 ++++++++++
1 file changed, 10 insertions(+)
@@ -5141,6 +5141,16 @@ sub process {}}+my$underscore_smp_barriers=qr{__smp_($smp_barriers)}x;++if($realfile!~m@^include/asm-generic/@&&+$realfile!~m@/barrier\.h$@&&+$line=~m/\b($underscore_smp_barriers)\s*\(/&&+$line!~m/^.\s*\#\s*define\s+($underscore_smp_barriers)\s*\(/){+WARN("MEMORY_BARRIER",+"__smp memory barriers shouldn't be used outside barrier.h and asm-generic\n".$herecurr);+}+#checkforwaitqueue_activewithoutacomment.if($line=~/\bwaitqueue_active\s*\(/){if(!ctx_has_comment($first_line,$linenr)){
From: "Michael S. Tsirkin" <mst@redhat.com> Date: 2016-01-10 11:57:29
Add virt_ barriers to list of barriers to check for
presence of a comment.
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
scripts/checkpatch.pl | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
@@ -5131,7 +5131,8 @@ sub process {}x;my$all_barriers=qr{$barriers|-smp_($smp_barriers)+smp_($smp_barriers)|+virt_($smp_barriers)}x;if($line=~/\b($all_barriers)\s*\(/){
}
}
# check for memory barriers without a comment.
- if ($line =~ /\b(mb|rmb|wmb|read_barrier_depends|smp_mb|smp_rmb|smp_wmb|smp_read_barrier_depends)\(/) {
+
+ my $barriers = qr{
+ mb|
+ rmb|
+ wmb|
+ read_barrier_depends
+ }x;
+ my $smp_barriers = qr{
+ store_release|
+ load_acquire|
+ store_mb|
+ ($barriers)
+ }x;
If I use a variable called $smp_barriers, I'd expect
it to actually be the smp_barriers, not to have to
prefix it with smp_ before using it.
my $smp_barriers = qr{
smp_store_release|
smp_load_acquire|
smp_store_mb|
smp_read_barrier_depends
}x;
or
my $smp_barriers = qr{
smp_(?:store_release|load_acquire|store_mb|read_barrier_depends)
}x;
From: Joe Perches <joe@perches.com> Date: 2016-01-10 15:08:47
On Sun, 2016-01-10 at 13:57 +0200, Michael S. Tsirkin wrote:
Introduction of __smp barriers cleans up a bunch of duplicate code, but
it gives people an additional handle onto a "new" set of barriers - just
because they're prefixed with __* unfortunately doesn't stop anyone from
using it (as happened with other arch stuff before.)
Add a checkpatch test so it will trigger a warning.
If I use a variable called $smp_barriers, I'd expect
it to actually be the smp_barriers, not to have to
prefix it with smp_ before using it.
my $smp_barriers = qr{
smp_store_release|
smp_load_acquire|
smp_store_mb|
smp_read_barrier_depends
That's missing (?:barriers) too.
btw: shouldn't this also have
smp_mb__(?:before|after)_atomic
?
}
}
# check for memory barriers without a comment.
- if ($line =~ /\b(mb|rmb|wmb|read_barrier_depends|smp_mb|smp_rmb|smp_wmb|smp_read_barrier_depends)\(/) {
+
+ my $barriers = qr{
+ mb|
+ rmb|
+ wmb|
+ read_barrier_depends
+ }x;
+ my $smp_barriers = qr{
+ store_release|
+ load_acquire|
+ store_mb|
+ ($barriers)
+ }x;
If I use a variable called $smp_barriers, I'd expect
it to actually be the smp_barriers, not to have to
prefix it with smp_ before using it.
my $smp_barriers = qr{
smp_store_release|
smp_load_acquire|
smp_store_mb|
smp_read_barrier_depends
}x;
or
my $smp_barriers = qr{
smp_(?:store_release|load_acquire|store_mb|read_barrier_depends)
}x;
Yes but virt barriers (added in patch 3) are same things but prefixed
with virt_. So we need the stems without smp_ prefix. If smp_barriers is
too confusing we'll just need to give them some other name.
How about:
my $smp_barrier_stems
?
If I use a variable called $smp_barriers, I'd expect
it to actually be the smp_barriers, not to have to
prefix it with smp_ before using it.
my $smp_barriers = qr{
smp_store_release|
smp_load_acquire|
smp_store_mb|
smp_read_barrier_depends
That's missing (?:barriers) too.
My version has it but need to add ?: to avoid
a capture group.
btw: shouldn't this also have
smp_mb__(?:before|after)_atomic
?