RE: [PATCH v3] powerpc/cache: add cache flush operation for various e500
From: Yuantian Tang <hidden>
Date: 2015-06-10 02:01:01
Please see my replay inline. ________________________________________ From: Wood Scott-B07421 Sent: Wednesday, June 10, 2015 6:28 AM To: Tang Yuantian-B29983 Cc: Wood Scott-B07421; linuxppc-dev@lists.ozlabs.org; linux-kernel@vger.ker= nel.org; Zhao Chenhui-B35336; Tang Yuantian Subject: Re: [PATCH v3] powerpc/cache: add cache flush operation for variou= s e500 On Tue, 2015-06-09 at 09:53 +0800, Yuantian.Tang@freescale.com wrote:
From: Tang Yuantian <redacted>
Various e500 core have different cache architecture, so they
need different cache flush operations. Therefore, add a callback
function cpu_flush_caches to the struct cpu_spec. The cache flush
operation for the specific kind of e500 is selected at init time.
The callback function will flush all caches inside the current cpu.
Signed-off-by: Chenhui Zhao <redacted>
Signed-off-by: Tang Yuantian <redacted>
---
v3:
- change all flush_caches to cpu_down_flush
- replace whitespace with tab[snip]
.cpu_setup =3D __setup_cpu_e500v2, .machine_check =3D machine_check_e500,
.platform =3D "ppc8548",
+ .cpu_down_flush =3D cpu_down_flush_e500v2,It's still not lined up. I'm not a fan of the "line up all the =3D" style, as it's a pain to maintain (and can be harder to read if the "=3D" is too far to the right), but mixing the two is worse. [Yuantian]: I need more clear about this. The only difference here is that my function puts ONE tab before "=3D" and = ONE white space after "=3D";=20 but the other functions in this structure use TWO tabs before "=3D". Is th= at what you want? Regards, Yuantian =20 -Scott