Thread (4 messages) flat view 4 messages, 2 authors, 2015-06-10

Re: [PATCH v3] powerpc/cache: add cache flush operation for various e500

From: Scott Wood <hidden>
Date: 2015-06-09 22:28:43
Also in: lkml

On Tue, 2015-06-09 at 09:53 +0800, Yuantian.Tang@freescale.com wrote:
From: Tang Yuantian <redacted>

Various e500 core have different cache architecture, so they
need different cache flush operations. Therefore, add a callback
function cpu_flush_caches to the struct cpu_spec. The cache flush
operation for the specific kind of e500 is selected at init time.
The callback function will flush all caches inside the current cpu.

Signed-off-by: Chenhui Zhao <redacted>
Signed-off-by: Tang Yuantian <redacted>
---
v3:
      - change all flush_caches to cpu_down_flush
      - replace whitespace with tab
[snip]
                .cpu_setup              = __setup_cpu_e500v2,
              .machine_check          = machine_check_e500,
              .platform               = "ppc8548",
+             .cpu_down_flush = cpu_down_flush_e500v2,
It's still not lined up.  I'm not a fan of the "line up all the =" 
style, as it's a pain to maintain (and can be harder to read if the "=" 
is too far to the right), but mixing the two is worse.

-Scott
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help