Re: [RFC PATCH 08/11] kvm: powerpc: book3s: Support building HV and PR KVM as module
From: Alexander Graf <hidden>
Date: 2013-09-30 10:04:06
On 27.09.2013, at 15:08, Aneesh Kumar K.V wrote:
Alexander Graf [off-list ref] writes: =20quoted
On 27.09.2013, at 12:03, Aneesh Kumar K.V wrote: =20quoted
diff --git a/arch/powerpc/kvm/book3s_64_mmu_host.c =
b/arch/powerpc/kvm/book3s_64_mmu_host.c
quoted
quoted
index fd5b393..775d368 100644--- a/arch/powerpc/kvm/book3s_64_mmu_host.c +++ b/arch/powerpc/kvm/book3s_64_mmu_host.c@@ -27,6 +27,7 @@#include <asm/machdep.h> #include <asm/mmu_context.h> #include <asm/hw_irq.h> +=20 Stray whitespace change =20=20 will fix =20quoted
quoted
#include "trace_pr.h" =20 #define PTE_SIZE 12diff --git a/arch/powerpc/kvm/book3s_emulate.c =
b/arch/powerpc/kvm/book3s_emulate.c
quoted
quoted
index b9841ad..20d03c2 100644--- a/arch/powerpc/kvm/book3s_emulate.c +++ b/arch/powerpc/kvm/book3s_emulate.c@@ -172,7 +172,7 @@ int kvmppc_core_emulate_op_pr(struct kvm_run =
*run, struct kvm_vcpu *vcpu,
quoted
quoted
vcpu->arch.mmu.tlbie(vcpu, addr, large); break; } -#ifdef CONFIG_KVM_BOOK3S_64_PR +#ifdef CONFIG_KVM_BOOK3S_PR=20 Why?=20 If i have CONFIG_KVM_BOOK3S_64_PR=3Dm #ifdef CONFIG_KVM_BOOK3S_64_PR =
will
not work. There is a runtime check I can use IS_ENABLED(). But didn't want to do those. Hence moved to the symbol which will be set as CONFIG_KVM_BOOK3S_PR =3D y
Ah, I see. The naming starts to get really confusing. Could you please = give this a slightly better name, such as CONFIG_KVM_BOOK3S_PR_POSSIBLE = or such, so that it's obvious that this #ifdef doesn't mean "option is = enabled", but instead means "option can potentially be enabled through a = module". Alex