quoted
Create an entry for the BG/P chips, include bits to accomodate
the double fp2 fpu and the special MMU considerations like L1
writethrough.
RFC Note: this patch fails scripts/checkpatch.pl because I
matched coding style of the surrounding existing code. Would
you rather have something checkpatch.pl clean or something
which is consistent with the surrounding code style?
Stay consistent. You're welcome to my next checkpatch burning
ceremony :-)
I'll make t-shirts for us!
quoted
#define PPC_FEATURE_POWER6_EXT 0x00000200
#define PPC_FEATURE_ARCH_2_06 0x00000100
#define PPC_FEATURE_HAS_VSX 0x00000080
+#define PPC_FEATURE_HAS_FPU_FP2 0x00000040
Any chance for a better name ?
I've painted this particular bike shed with Eric already :-)
It's an extension to the FPU called FP2
(https://wiki.alcf.anl.gov/images/d/d9/PPC440_FP2_arch.pdf).
So PPC_FEATURE_HAS_FPU -> PPC_FEATURE_HAS_FPU_FP2.
I think the name is right as he has it.
Mikey