On Thu, 20 Jan 2011 17:55:02 +0100
torbenh [off-list ref] wrote:
On Thu, Jan 20, 2011 at 08:34:48AM -0800, Greg KH wrote:
quoted
On Thu, Jan 20, 2011 at 04:58:13PM +0100, Torben Hohn wrote:
quoted
the -rt patches change the console_semaphore to console_mutex.
so a quite large chunk of the patches changes all
acquire/release_console_sem() to acquire/release_console_mutex()
Why not just change the functionality of the existing function to be a
mutex in the rt patches, instead of having to rename it everywhere?
i hope that Thomas already did this in his upcoming -rt series.
quoted
quoted
this commit makes things use more neutral function names
which dont make implications about the underlying lock.
the only real change is the return value of console_trylock
which is inverted from try_acquire_console_sem()
Signed-off-by: Torben Hohn <redacted>
CC: Thomas Gleixner <redacted>
I don't mind this rename, but is it really going to help anything out?
What's the odds of the -rt portion of this patch ever making it to
mainline?
the -rt portion only changes the semaphore to a mutex.
since the console_sem is used with mutex semantics, i dont see any
reason, not to merge that portion too.
i am just trying to shrink the -rt patch to make it more maintanable :)
Yeah, I think it's a better name and if we can indeed switch that
semaphore to a mutex then that's a good thing to do.