On Thu, Jan 20, 2011 at 04:58:13PM +0100, Torben Hohn wrote:
the -rt patches change the console_semaphore to console_mutex.
so a quite large chunk of the patches changes all
acquire/release_console_sem() to acquire/release_console_mutex()
Why not just change the functionality of the existing function to be a
mutex in the rt patches, instead of having to rename it everywhere?
this commit makes things use more neutral function names
which dont make implications about the underlying lock.
the only real change is the return value of console_trylock
which is inverted from try_acquire_console_sem()
Signed-off-by: Torben Hohn <redacted>
CC: Thomas Gleixner <redacted>
I don't mind this rename, but is it really going to help anything out?
What's the odds of the -rt portion of this patch ever making it to
mainline?
thanks,
greg k-h