On Thu, 2008-02-28 at 11:20 -0600, Nathan Lynch wrote:
Badari Pulavarty wrote:
quoted
+static struct notifier_block pseries_smp_nb = {
Rename this to pseries_mem_nb?
Sure.
quoted
+ .notifier_call = pseries_memory_notifier,
+};
+
+static int __init pseries_memory_hotplug_init(void)
+{
+ if (firmware_has_feature(FW_FEATURE_LPAR))
+ pSeries_reconfig_notifier_register(&pseries_smp_nb);
+
+ return 0;
+}
+arch_initcall(pseries_memory_hotplug_init);
arch_initcall doesn't seem appropriate. __initcall should be fine.
Okay, if you say so :)
I based the code on arch/powerpc/platforms/pseries/hotplug-cpu.c
Thanks,
Badari