Badari Pulavarty wrote:
+static struct notifier_block pseries_smp_nb = {
Rename this to pseries_mem_nb?
+ .notifier_call = pseries_memory_notifier,
+};
+
+static int __init pseries_memory_hotplug_init(void)
+{
+ if (firmware_has_feature(FW_FEATURE_LPAR))
+ pSeries_reconfig_notifier_register(&pseries_smp_nb);
+
+ return 0;
+}
+arch_initcall(pseries_memory_hotplug_init);
arch_initcall doesn't seem appropriate. __initcall should be fine.