Re: [PATCH v4 0/3] OF-platform PATA driver
From: Olof Johansson <hidden>
Date: 2008-01-15 16:30:03
Also in:
linux-ide
Hi, I've applied 1/3 and 2/3 together with my electra_ide move to pasemi.git for-2.6.25, and will ask Paul to pull that. Kumar said he'd take 3/3. I also added the const to the match table as spotted by Stephen. -Olof On Wed, Jan 09, 2008 at 10:08:52PM +0300, Anton Vorontsov wrote:
Hi all, Here is the resend (aka v4) version of the OF-platform PATA driver and related patches. Changes since v3: - Acked-by: Paul Mundt [off-list ref] - In the powerpc specific patch: update defconfig and use machine_device_initcall -- this is new call found in the galak/powerpc.git. Changes since v2: - "PPC" added to PATA_PLATFORM "depends on" Kconfig entry; I didn't remove EMBEDDED "depends on" -- this wasn't discussed much and these patches should not depend on the decision. - cosmetic fixes; - "s/ioport_shift/reg_shift/g" patch dropped. Changes since v1: - __pata_platform_probe now accepts pio_mask argument; - pata-platform compatible property renamed to ata-generic; - pata_of_platform understands pio-mode property. It's used to pass pio_mask to the __pata_platform_probe. That is, in ata-generic context pio-mode means "pio mode the bus already configured for"; - New optional patch that renames pata_platform_info's ioport_shift to reg_shift. Changes since RFC: - nuked drivers/ata/pata_platform.h; - powerpc bits: proper localbus node added. -- Anton Vorontsov email: cbou@mail.ru backup email: ya-cbou@yandex.ru irc://irc.freenode.net/bd2 _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev