Re: Small fixes for the Ebony device tree
From: David Gibson <hidden>
Date: 2007-05-15 01:17:04
On Mon, May 14, 2007 at 02:59:31PM +0200, Segher Boessenkool wrote:
quoted
- i-cache-size = <0>; - d-cache-size = <0>; + i-cache-size = <2000000>; /* 32 kB */ + d-cache-size = <2000000>; /* 32 kB */That's 32MB, not 32kB. Better fix this :-)
Duh. Fixed.
quoted
UIC0: interrupt-controller0 {quoted
UIC1: interrupt-controller1 {It's a shame you can't use unit addresses for these since you use "dcr-reg" instead of "reg". Oh well.quoted
SDRAM0: sdram { - device_type = "memory-controller"; compatible = "ibm,sdram-440gp", "ibm,sdram";Maybe rename the node to "memory-controller"?
Hmm, yeah, I guess so.
quoted
+ SRAM0: sram { + compatible = "ibm,sram440gp"; + dcr-reg = <020 8 00a 1>; + };Is this thing _only_ addressable over DCRs? Weird.
Well... the control registers are certainly DCR only. I guess there's the actual SRAM itself, though whether this belongs in this node, or elsewhere isn't immediately clear. I haven't yet investigated how the SRAM is mapped (it depends on DIP switch settings) so I'm certainly not considering this node complete yet.
quoted
MAL0: mcmal { - device_type = "mcmal-dma"; + device_type = "dma-controller"; compatible = "ibm,mcmal-440gp", "ibm,mcmal";Remove "device_type", change name to "dma-controller"?
Don't really want to remove the device_type, because the MAL driver looks for it at present. Don't really want to change the name, since that might encourage confusion with the other (more conventional) DMA controller.
quoted
EBC0: ebc { - device_type = "ibm,ebc"; compatible = "ibm,ebc-440gp";You forgot "ibm,ebc" here.
Hmm.. yeah, I guess. Revised patch coming shortly. -- David Gibson | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_ | _way_ _around_! http://www.ozlabs.org/~dgibson