On Tue, 19 Sep 2006 13:42:58 +0100 David Howells [off-list ref] wrote:
Stephen Rothwell [off-list ref] wrote:
quoted
+void _insb(volatile u8 __iomem *port, void *buf, int ns)
+{
+ asm volatile("sync");
+ if (ns <= 0)
+ return;
What is "ns" meant to do? It seems to degrade the _insb() op to just a sync,
but is that correct?
"ns" is the count (maybe I should rename the parameter, but that is what
was in the prototype in io.h). The "sync" is in the same place as it was
in the assembler code that this replaces.
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
http://www.canb.auug.org.au/~sfr/