On 01/09/2026 09:14, HungTsung Huang wrote:
Hi Arend,
quoted
Actually there is a checkpatch warning that line with the STA_1X check
is 82 characters. So my suggestion please make it FAST_ROAMING instead
of ROAM_OFFLOAD and swap the two checks to fix the checkpatch warning.
Thank you for your suggestion. We will rename it to NL80211_EXT_FEATURE_FAST_ROAM_OFFLOAD.
The name reflects that userspace offloads fast-roaming handling to the driver/firmware,
and it covers both FT and OKC. We will also reorder the checks to avoid the line-length warning.
As this is indicating a driver feature the "_OFFLOAD" part is implied.
At least that is how I look at it. With the 80 char limit the long name
can be a drag in places.
Regards,
Arend