Re: [PATCH 1/4 v3] mac80211: Enable mesh security from userspace
From: Johannes Berg <johannes@sipsolutions.net>
Date: 2011-03-07 19:03:57
On Mon, 2011-03-07 at 10:47 -0800, Javier Cardona wrote:
quoted
quoted
+ * @is_secure: or notGiven what we just discussed over in the other thread, should we rename this to "userspace_station_mgmt" or something like that?Are you suggesting to change the name of the flag both in nl80211 and cfg80211?
Yeah, I was.
Currently ENABLE_SECURITY means "let userspace manage stations", but also "ok to accept mesh management frames from secure mesh peers". And when the Authenticated Mesh Peering Exchange is implemented, it will probably mean "verify mesh peering frames in userspace" and "protect mesh peering frames". You either do all these tasks or none, so for nl80211 I would prefer a single flag.
Indeed. I forgot about the RSN checking part etc. I suppose we should just leave it as is then.
quoted
Also, does it make sense to advertise support for this somehow? Otherwise the new tools will have strange failure cases on older kernels;Ah, I see. Older kernels would not return an error to userspace if an attempt to set a non existing flag was made, right?
Right.
Are you suggesting to define something like an NL80211_MESHCONF_CAPABILITIES mask?
I haven't thought about how I'd do it really -- yes something like that might make sense.
quoted
and I can also imagine situations where the mesh APIs are in firmware or so that can't cope with userspace station mgmt.Ah mesh in firmware... who would want to do that? :)
:-) johannes