proc filesystem · Maintained
Paths
- F
Documentation/filesystems/proc.rst - F
fs/proc/ - F
include/linux/proc_fs.h - F
tools/testing/selftests/proc/
Last 30 days
Active reviewers (last 30 days)
-
Michal Hocko <mhocko@suse.com>
3 attestations (3 Acked-by) · last on 2026-09-21 -
SJ Park <sj@kernel.org>
2 attestations (2 Reviewed-by) · last on 2026-09-21 -
Gregory Price (Meta) <gourry@gourry.net>
2 attestations (2 Reviewed-by) · last on 2026-09-21 -
Lorenzo Stoakes (ARM) <ljs@kernel.org>
2 attestations (2 Reviewed-by) · last on 2026-09-21 -
Marc Zyngier <maz@kernel.org>
2 attestations (2 Acked-by) · last on 2026-09-17 -
Claudio Imbrenda <imbrenda@linux.ibm.com>
2 attestations (2 Acked-by) · last on 2026-09-17 -
Anup Patel <anup@brainfault.org>
2 attestations (2 Acked-by) · last on 2026-09-17
Recent patches
Most-recent 30 patches in this subsystem on linux-trace-kernel (capped at 30), ordered by date desc.
-
HOTtoday
[PATCH v3 3/9] mm: use hw_pte_t for generic PTE table storage
2026-09-22 · Muhammad Usama Anjum <hidden> -
COOLING9d
REVIEWED: 16 (16M) [PATCH v4 13/15] fs: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Ye Liu <hidden> -
HOTtoday
IN LINUX-NEXT [PATCH v5 10/17] mm/page-flags: check page/folio->private instead of PG_private
2026-09-21 · Zi Yan <ziy@nvidia.com> -
HOTtoday
IN LINUX-NEXT: 11 (11M) [PATCH v3 28/40] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
2026-09-17 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COOLING7d
REVIEWED: 11 (11M) [PATCH v2 28/40] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
2026-09-14 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COOLING12d
[PATCH v4 10/16] mm/page-flags: check page/folio->private instead of PG_private
2026-09-14 · Zi Yan <ziy@nvidia.com> -
COLD18d
[PATCH v7 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
2026-09-12 · André Almeida <andrealmeid@igalia.com> -
COLD18d
[PATCH v7 1/6] treewide: Get rid of get_task_comm()
2026-09-12 · André Almeida <andrealmeid@igalia.com> -
COOLING13d
REVIEWED: 16 (16M) [PATCH v3 13/15] fs: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Ye Liu <hidden> -
COLD20d
[PATCH v6 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
2026-09-10 · André Almeida <andrealmeid@igalia.com> -
COLD20d
[PATCH v6 1/6] treewide: Get rid of get_task_comm()
2026-09-10 · André Almeida <andrealmeid@igalia.com> -
COLD16d
[PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COLD16d
[PATCH v3 09/14] mm/page-flags: check page/folio->private instead of PG_private
2026-09-08 · Zi Yan <ziy@nvidia.com> -
COLD21d
REVIEWED: 4 (4M) [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
2026-09-07 · Ye Liu <hidden> -
COOLING7d
[PATCH v2 3/8] mm: use hw_pte_t for generic PTE table storage
2026-09-03 · Muhammad Usama Anjum <hidden> -
COLD27d
[PATCH v2 09/14] mm/page-flags: check page/folio->private instead of PG_private
2026-08-31 · Zi Yan <ziy@nvidia.com> -
COLD30d
[PATCH v5 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
2026-08-27 · André Almeida <andrealmeid@igalia.com> -
COLD30d
[PATCH v5 1/6] treewide: Get rid of get_task_comm()
2026-08-27 · André Almeida <andrealmeid@igalia.com> -
COLD31d
[PATCH 6/6] userfaultfd: collapse VM_UFFD_{MISSING,WP,MINOR,RWP} into single VM_UFFD
2026-08-23 · "Mike Rapoport (Microsoft)" <rppt@kernel.org> -
COLD15d
[RFC PATCH 01/57] mm: add pte_folio()
2026-08-16 · Kiryl Shutsemau <hidden> -
COLD41d
IN MM: 17 (17M) [PATCH v5 02/16] mm: provide vma_[flags_]is_cow_mapping() and remove is_cow_mapping()
2026-08-13 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COLD50d
[PATCH] tracing: report buffer memory in /proc/meminfo
2026-08-10 · Xiang Gao <hidden> -
COLD48d
[PATCH v4 18/20] mm/vma: make MAP_PRIVATE-mapped /dev/zero mappings truly anonymous
2026-08-06 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COLD48d
[PATCH v4 02/20] mm: provide vma_[flags_]is_cow_mapping() and remove is_cow_mapping()
2026-08-06 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COLD47d
[PATCH 4/9] mm: use hw_pte_t for generic PTE table storage
2026-08-06 · Muhammad Usama Anjum <hidden> -
COLD27d
[PATCH RFC 10/14] mm/page-flags: introduce folio_test_fs_private()
2026-08-01 · Zi Yan <ziy@nvidia.com> -
COLD27d
[PATCH RFC 09/14] mm/page-flags: check page/folio->private instead of PG_private
2026-08-01 · Zi Yan <ziy@nvidia.com> -
STALE61d
[PATCH RFC 04/11] mm: use hw_pte_t for generic PTE table storage
2026-07-27 · Muhammad Usama Anjum <hidden> -
STALE187d
[PATCH 04/53] VFS: use global wait-queue table for d_alloc_parallel()
2026-03-12 · NeilBrown <hidden> -
STALE198d
[PATCH v3 12/12] treewide: change inode->i_ino from unsigned long to u64
2026-03-04 · Jeff Layton <jlayton@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE187d
[PATCH 04/53] VFS: use global wait-queue table for d_alloc_parallel()
2026-03-12 · NeilBrown <hidden> -
STALE61d
[PATCH RFC 04/11] mm: use hw_pte_t for generic PTE table storage
2026-07-27 · Muhammad Usama Anjum <hidden>