Reviews by ljs@kernel.org
· linux-trace-kernel
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-trace-kernel archive.
87 attestations . (87 Reviewed-by)
-
COOLING5d
REVIEWED: 13 (11M) [PATCH v4 15/15] security/landlock: convert thread iterator to for_each_thread_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) [PATCH v4 14/15] lib: convert process iterator to for_each_process_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) [PATCH v4 13/15] fs: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 33 (33M) [PATCH v4 12/15] unwind: convert process/thread iterator to for_each_process_thread_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 33 (33M) [PATCH v4 11/15] tracing/fgraph: convert process/thread iterator to for_each_process_thread_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 10/15] sched: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 09/15] rcu: convert process/thread iterator to for_each_process_thread_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 08/15] locking/lockdep: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 07/15] hung_task: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 06/15] freezer: convert thread iterator to for_each_thread_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 05/15] cpu/hotplug: convert process iterator to for_each_process_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 16 (16M) [PATCH v4 04/15] mm/memory-failure: convert process iterator to for_each_process_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 31 (31M) [PATCH v4 03/15] mm/ksm: convert process iterator to for_each_process_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) [PATCH v4 02/15] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
2026-09-21 · Reviewed-by -
COOLING5d
REVIEWED: 17 (17M) [PATCH v4 01/15] sched: introduce for_each_process_rculock and for_each_thread_rculock
2026-09-21 · Reviewed-by -
COOLING9d
REVIEWED: 13 (11M) [PATCH v3 15/15] security/landlock: convert thread iterator to for_each_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 15 (15M) [PATCH v3 14/15] lib: convert process iterator to for_each_process_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 15 (15M) [PATCH v3 13/15] fs: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 12/15] unwind: convert process/thread iterator to for_each_process_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 11/15] tracing/fgraph: convert process/thread iterator to for_each_process_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 10/15] sched: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 09/15] rcu: convert process/thread iterator to for_each_process_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 08/15] locking/lockdep: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 07/15] hung_task: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 06/15] freezer: convert thread iterator to for_each_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 05/15] cpu/hotplug: convert thread iterator to for_each_thread_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 16 (16M) [PATCH v3 04/15] mm/memory-failure: convert process iterator to for_each_process_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 31 (31M) [PATCH v3 03/15] mm/ksm: convert process iterator to for_each_process_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 15 (15M) [PATCH v3 02/15] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
2026-09-11 · Reviewed-by -
COOLING9d
REVIEWED: 17 (17M) [PATCH v3 01/15] sched: introduce for_each_process_rculock and for_each_thread_rculock
2026-09-11 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
2026-09-07 · Reviewed-by -
COLD17d
REVIEWED: 9 (9M) Re: [PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
2026-09-07 · Reviewed-by -
COLD27d
REVIEWED: 9 (9M) Re: [PATCH 4/6] userfaultfd: rename vm_userfaultfd_ctx to vm_uffd_state
2026-08-24 · Reviewed-by -
COLD27d
REVIEWED: 9 (9M) Re: [PATCH 2/6] userfaultfd: constify VMA parameter of userfaultfd_*() helpers
2026-08-24 · Reviewed-by -
COLD27d
REVIEWED: 9 (9M) Re: [PATCH 1/6] mm/gup: move gup_can_follow_protnone() to gup.c
2026-08-24 · Reviewed-by -
STALE68d
IN MM: 21 (21M) [PATCH v6 3/9] mm: use enum migrate_reason instead of int for migration reason parameters
2026-07-14 · Reviewed-by -
STALE75d
REVIEWED: 9 (9M) Re: [PATCH v5 3/9] mm: use enum migrate_reason instead of int for migration reason parameters
2026-07-01 · Reviewed-by -
STALE106d
REVIEWED: 9 (9M) Re: [PATCH v2 1/4] mm: use mapping_mapped to simplify the code
2026-06-11 · Reviewed-by -
STALE109d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v19 11/14] mm/khugepaged: Introduce mTHP collapse support
2026-06-05 · Reviewed-by -
STALE109d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v19 06/14] mm/khugepaged: generalize collapse_huge_page for mTHP collapse
2026-06-05 · Reviewed-by -
STALE109d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v19 06/14] mm/khugepaged: generalize collapse_huge_page for mTHP collapse
2026-06-05 · Reviewed-by -
STALE109d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v19 10/14] mm/khugepaged: introduce collapse_possible_orders helper functions
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 10 (9M) [PATCH mm-unstable v19 14/14] Documentation: mm: update the admin guide for mTHP collapse
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 29 (29M) [PATCH mm-unstable v19 13/14] mm/khugepaged: run khugepaged for all orders
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 26 (26M) [PATCH mm-unstable v19 12/14] mm/khugepaged: avoid unnecessary mTHP collapse attempts
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 28 (28M) [PATCH mm-unstable v19 09/14] mm/khugepaged: improve tracepoints for mTHP orders
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 25 (25M) [PATCH mm-unstable v19 08/14] mm/khugepaged: add per-order mTHP collapse failure statistics
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 29 (29M) [PATCH mm-unstable v19 07/14] mm/khugepaged: skip collapsing mTHP to smaller orders
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 25 (25M) [PATCH mm-unstable v19 05/14] mm/khugepaged: require collapse_huge_page to enter/exit with the lock dropped
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 28 (28M) [PATCH mm-unstable v19 04/14] mm/khugepaged: generalize __collapse_huge_page_* for mTHP support
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 32 (32M) [PATCH mm-unstable v19 03/14] mm/khugepaged: rework max_ptes_* handling with helper functions
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 36 (35M) [PATCH mm-unstable v19 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-06-05 · Reviewed-by -
STALE109d
IN MM: 36 (35M) [PATCH mm-unstable v19 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-06-05 · Reviewed-by -
STALE113d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v18 08/14] mm/khugepaged: add per-order mTHP collapse failure statistics
2026-06-01 · Reviewed-by -
STALE113d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v18 05/14] mm/khugepaged: require collapse_huge_page to enter/exit with the lock dropped
2026-06-01 · Reviewed-by -
STALE113d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v18 04/14] mm/khugepaged: generalize __collapse_huge_page_* for mTHP support
2026-06-01 · Reviewed-by -
STALE113d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v18 03/14] mm/khugepaged: rework max_ptes_* handling with helper functions
2026-06-01 · Reviewed-by -
STALE113d
REVIEWED: 10 (9M) [PATCH mm-unstable v18 14/14] Documentation: mm: update the admin guide for mTHP collapse
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 29 (29M) [PATCH mm-unstable v18 13/14] mm/khugepaged: run khugepaged for all orders
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 26 (26M) [PATCH mm-unstable v18 12/14] mm/khugepaged: avoid unnecessary mTHP collapse attempts
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 28 (28M) [PATCH mm-unstable v18 09/14] mm/khugepaged: improve tracepoints for mTHP orders
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 13 (13M) [PATCH mm-unstable v18 07/14] mm/khugepaged: skip collapsing mTHP to smaller orders
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 36 (35M) [PATCH mm-unstable v18 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-05-22 · Reviewed-by -
STALE113d
REVIEWED: 36 (35M) [PATCH mm-unstable v18 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-05-22 · Reviewed-by -
STALE124d
REVIEWED: 10 (9M) [PATCH mm-unstable v17 14/14] Documentation: mm: update the admin guide for mTHP collapse
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 29 (29M) [PATCH mm-unstable v17 13/14] mm/khugepaged: run khugepaged for all orders
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 26 (26M) [PATCH mm-unstable v17 12/14] mm/khugepaged: avoid unnecessary mTHP collapse attempts
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 28 (28M) [PATCH mm-unstable v17 09/14] mm/khugepaged: improve tracepoints for mTHP orders
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 13 (13M) [PATCH mm-unstable v17 07/14] mm/khugepaged: skip collapsing mTHP to smaller orders
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 36 (35M) [PATCH mm-unstable v17 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-05-11 · Reviewed-by -
STALE124d
REVIEWED: 36 (35M) [PATCH mm-unstable v17 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-05-11 · Reviewed-by -
STALE141d
REVIEWED: 10 (9M) [PATCH 7.2 v16 13/13] Documentation: mm: update the admin guide for mTHP collapse
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 29 (29M) [PATCH 7.2 v16 12/13] mm/khugepaged: run khugepaged for all orders
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 26 (26M) [PATCH 7.2 v16 11/13] mm/khugepaged: avoid unnecessary mTHP collapse attempts
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 28 (28M) [PATCH 7.2 v16 08/13] mm/khugepaged: improve tracepoints for mTHP orders
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 12 (12M) [PATCH 7.2 v16 06/13] mm/khugepaged: skip collapsing mTHP to smaller orders
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 35 (34M) [PATCH 7.2 v16 02/13] mm/khugepaged: generalize alloc_charge_folio()
2026-04-19 · Reviewed-by -
STALE141d
REVIEWED: 35 (34M) [PATCH 7.2 v16 01/13] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-04-19 · Reviewed-by -
STALE163d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v15 13/13] Documentation: mm: update the admin guide for mTHP collapse
2026-03-17 · Reviewed-by -
STALE163d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v15 12/13] mm/khugepaged: run khugepaged for all orders
2026-03-17 · Reviewed-by -
STALE163d
REVIEWED: 9 (9M) Re: [PATCH mm-unstable v15 11/13] mm/khugepaged: avoid unnecessary mTHP collapse attempts
2026-03-17 · Reviewed-by