On 20.08.2026 20:04, David Hildenbrand (Arm) wrote:
quoted
/* This part must be outside protection */> diff --git a/mm/cma.c b/mm/cma.c
index a10ea37a261d..1e1ebae79090 100644
--- a/mm/cma.c
+++ b/mm/cma.c
@@ -936,6 +936,141 @@ struct page *cma_alloc_frozen_compound(struct cma *cma, unsigned int order)
return __cma_alloc_frozen(cma, 1 << order, order, gfp);
}
+static int cma_range_alloc_at(struct cma *cma, struct cma_memrange *cmr,
+ unsigned long offset, unsigned long count,
+ struct page **pagep, gfp_t gfp)
+{
+ struct page *page = NULL;
+ unsigned long pfn;
+ int ret = -EBUSY;
+
+ spin_lock_irq(&cma->lock);
+
+ /*
+ * If the request is larger than the available number of pages, stop
+ * right away.
+ */
+ if (count > cma->available_count)
+ goto unlock;
+
+ ret = bitmap_allocate(cmr->bitmap, offset, count);
+ if (ret < 0)
+ goto unlock;
+
+ pfn = cmr->base_pfn + offset;
+ page = pfn_to_page(pfn);
+
+ /*
+ * Do not hand out page ranges that are not contiguous, so
+ * callers can just iterate the pages without having to worry
+ * about these corner cases.
+ */
+ if (!page_range_contiguous(page, count)) {
+ pr_warn_ratelimited("%s: %s: skipping non-contiguous area [0x%lx-0x%lx]",
+ __func__, cma->name, pfn, pfn + count - 1);
+ ret = -EBUSY;
+ goto clear;
+ }
+
+ cma->available_count -= count;
+
+ /*
+ * It's safe to drop the lock here. We've marked this region for
+ * our exclusive use. If the migration fails we will take the
+ * lock again and unmark it.
+ */
+ spin_unlock_irq(&cma->lock);
+
+ mutex_lock(&cma->alloc_mutex);
+ ret = alloc_contig_frozen_range(pfn, pfn + count, ACR_FLAGS_CMA, gfp);
+ mutex_unlock(&cma->alloc_mutex);
+
There is quite some code duplication with cma_range_alloc(). Please try harder
to factor common code out and reuse it.
quoted
...
Also here, way too much code duplication with __cma_alloc_frozen().
There must be a better way :)
Maybe the existing 'alloc' functions could call 'alloc_at' variant internally
(with locks adjusted and moved out).
(I really prefer this direction of the patch set)
Definitely, I also like this approach much more than previous attempt with
'dynamically' instantiated cma regions.
Best regards
--
Marek Szyprowski, PhD
Samsung R&D Institute Poland