Re: [PATCH 1/3] tracing/user_events: Simplify data output in user_seq_show()
From: Steven Rostedt <rostedt@goodmis.org>
Date: 2026-06-11 12:59:57
Also in:
kernel-janitors, lkml
From: Steven Rostedt <rostedt@goodmis.org>
Date: 2026-06-11 12:59:57
Also in:
kernel-janitors, lkml
On Tue, 9 Jun 2026 18:44:04 +0200 Markus Elfring [off-list ref] wrote:
quoted
quoted
@@ -2800,8 +2800,7 @@ static int user_seq_show(struct seq_file *m, void *p) mutex_unlock(&group->reg_mutex); - seq_puts(m, "\n"); - seq_printf(m, "Active: %d\n", active); + seq_printf(m, "\nActive: %d\n", active); seq_printf(m, "Busy: %d\n", busy);This isn't a critical section and I find the original way easier to read.Would you prefer to use a seq_putc() call instead at such a source code place? https://elixir.bootlin.com/linux/v7.1-rc7/source/kernel/trace/trace_events_user.c#L2803
Sure, why not. -- Steve