Re: [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry
From: Masami Hiramatsu (Google) <mhiramat@kernel.org>
Date: 2025-09-23 23:07:25
Also in:
bpf, lkml
On Tue, 23 Sep 2025 17:20:00 +0800 Menglong Dong [off-list ref] wrote:
The fprobe_entry() is used by fgraph_ops, so rename it to fprobe_fgraph_entry to be more distinctive.
Sorry, NAK. fprobe is based on fgraph by design. So "fprobe_fgraph" sounds redundant. Thanks,
quoted hunk ↗ jump to hunk
Signed-off-by: Menglong Dong <redacted> --- kernel/trace/fprobe.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)diff --git a/kernel/trace/fprobe.c b/kernel/trace/fprobe.c index 6a205903b1ed..1785fba367c9 100644 --- a/kernel/trace/fprobe.c +++ b/kernel/trace/fprobe.c@@ -254,8 +254,8 @@ static inline int __fprobe_kprobe_handler(unsigned long ip, unsigned long parent return ret; } -static int fprobe_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops, - struct ftrace_regs *fregs) +static int fprobe_fgraph_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops, + struct ftrace_regs *fregs) { unsigned long *fgraph_data = NULL; unsigned long func = trace->func;@@ -340,7 +340,7 @@ static int fprobe_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops, /* If any exit_handler is set, data must be used. */ return used != 0; } -NOKPROBE_SYMBOL(fprobe_entry); +NOKPROBE_SYMBOL(fprobe_fgraph_entry); static void fprobe_return(struct ftrace_graph_ret *trace, struct fgraph_ops *gops,@@ -379,7 +379,7 @@ static void fprobe_return(struct ftrace_graph_ret *trace, NOKPROBE_SYMBOL(fprobe_return); static struct fgraph_ops fprobe_graph_ops = { - .entryfunc = fprobe_entry, + .entryfunc = fprobe_fgraph_entry, .retfunc = fprobe_return, }; static int fprobe_graph_active;-- 2.51.0
-- Masami Hiramatsu (Google) [off-list ref]