Thread (14 messages) 14 messages, 5 authors, 2025-09-24

Re: [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry

From: Steven Rostedt <rostedt@goodmis.org>
Date: 2025-09-23 09:38:17
Also in: bpf, lkml

On Tue, 23 Sep 2025 17:20:00 +0800
Menglong Dong [off-list ref] wrote:
The fprobe_entry() is used by fgraph_ops, so rename it to
fprobe_fgraph_entry to be more distinctive.
The change log should be more specific and state that this will allow
to have fprobes to use ftrace too. I didn't know why you did this until
I saw the second patch. As change logs should be self contain, it
should have enough information to not rely on knowing other commits to
understand why the patch is made.

-- Steve
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help